通信达公式指标大全 通达信资金量副图源码

通信达公式指标大全 通达信资金量副图源码
通信达公式指标大全

综投网(www.zt5.com)12月07日讯


VAR1:=1/WINNER(CLOSE);
 VAR2:=MA(CLOSE,13);
 VAR3:=100-ABS((CLOSE-VAR2)/VAR2*100);
 VAR4:=LLV(LOW,75);
 VAR5:=HHV(HIGH,75);
 VAR6:=(VAR5-VAR4)/100;
 VAR7:=SMA((CLOSE-VAR4)/VAR6,20,1);
 VAR8:=SMA((OPEN-VAR4)/VAR6,20,1);
 VAR9:=3*VAR7-2*SMA(VAR7,15,1);
 VARA:=3*VAR8-2*SMA(VAR8,15,1);
 VARB:=100-VARA;
 VARC:=IF(900101<DATE AND DATE<9999999,1,0);
进场系数: (100-VAR9)*VARC, , {000B0001};
出货量: MA(WINNER(CLOSE*0.95)*100,3)*VARC, , COLORYELLOW;
进货量: (100-IF(VAR1>5,IF(VAR1<100,VAR1,VAR3-10),0))*VARC, , COLORGREEN;
 VARD:=出货量>VAR3;
 VARE:=REF(LOW,1)*0.9;
 VARF:=LOW*0.9;
 VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
 VAR11:=EMA(VAR10,30);
 VAR12:=CLOSE-REF(CLOSE,1);
 VAR13:=MAX(VAR12,0);
 VAR14:=ABS(VAR12);
 VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
 VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
 VAR17:=BARSCOUNT(CLOSE);
 VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
 VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
 VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
 VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
 VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
 VAR1D:=SMA(VAR1C,4,1);
 VAR1E:=SMA(VAR1D,3,1);
 VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
 VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
 VAR21:=(HIGH+LOW+CLOSE)/3;
 VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
 VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
 VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
 VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
 VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
 VAR27:=REVERSE(VAR26);
 VAR28:=SMA(VAR26,3,1);
散户: SMA(VAR28,3,1)*VARC, , COLORGREEN;
庄家: SMA(散户,3,1)*VARC, , COLORRED;
见顶: IF(CROSS(散户,庄家) AND 散户<30,庄家,0)*VARC, , COLORRED;
见底: IF(CROSS(庄家,散户) AND 庄家>75,庄家,100)*VARC, , COLORGREEN;
 DRAWTEXT(CROSS(散户,庄家) AND 散户<30,庄家,'低吸 !'), ,COLORWHITE;
 DRAWTEXT(CROSS(庄家,散户) AND 庄家>75,庄家,''), , COLORGREEN;
预警: (IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50)*VARC, , {00050006};
 DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,35,'抄底'), , COLORYELLOW;
 DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,65,'逃顶'), , COLORCYAN;
 STICKLINE(VARD,100,25,1,0), , COLORCYAN;
 STICKLINE(1,出货量,0,1,0), , COLORYELLOW;
 STICKLINE(1,进货量,100,1,0), , {00010001};
 STICKLINE(VAR20,0,80,1,0), , COLORRED;
 STICKLINE(出货量>=REF(出货量,1),出货量,0,1,0), , COLORYELLOW;
 STICKLINE(出货量<REF(出货量,1),出货量,0,1,0), ,COLORBLUE;
万:AMOUNT/10000,COLORFF00FF,NODRAW; 
 VAR1M:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN)); 
流入万:IF(CLOSE>OPEN,VAR1M*(HIGH-LOW),IF(CLOSE<OPEN,VAR1M*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000,COLORRED,NODRAW; 
流出万:IF(CLOSE>OPEN,0-VAR1M*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1M*(HIGH-LOW),0-AMOUNT/2))/10000,COLOR00FF00,NODRAW; 
额万:流入万+流出万,COLORFFFF00,NODRAW;
 {线:=MA(CLOSE,1)-MA(CLOSE,6),NODRAW;} 
 YUWEI:=(MA(CLOSE,1)-MA(CLOSE,6))*10,NODRAW; 
 {量:(线),VOLSTICK;}
分界:0;
 STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,4,0)COLOR0D0C6A; 
 STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,3,0)COLOR0D06AA; 
 STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,1.5,0)COLOR2108C1; 
 STICKLINE(YUWEI>0 AND YUWEI>REF(YUWEI,1),0,YUWEI,0.5,0)COLOR9F5DFF; 
 STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,4,0)COLOR22736F; 
 STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,3,0)COLOR22AAD5; 
 STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,1.5,0)COLOR10C7BF; 
 STICKLINE(YUWEI>0 AND YUWEI<REF(YUWEI,1),0,YUWEI,0.5,0)COLOR80FFFF; 
 STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,4,0)COLOR1B7411; 
 STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,3,0)COLOR17A715; 
 STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,1.5,0)COLOR08D306; 
 STICKLINE(YUWEI<0 AND YUWEI<REF(YUWEI,1),0,YUWEI,0.5,0)COLOR40FF00; 
 STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,4,0)COLOR080E71; 
 STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,3,0)COLOR0B0E8C;
 STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,1.52,0)COLOR0905B0;
 STICKLINE(YUWEI<0 AND YUWEI>REF(YUWEI,1),0,YUWEI,0.5,0)COLOR0204F2;

返回顶部

返回首页